PVM Problems

JParker at coinstar.com JParker at coinstar.com
Tue May 1 08:24:57 PDT 2001

G'Day !

> > 
> The symptoms are that when I run the pvm shell, it starts correctly on 
> server, as verified by running administrative commands, but when I try 
> add a node, it returns a "terminated" and puts me back at my bash shell 
> prompt.  I can then rsh or ssh over to the node and verify the pvmd is 
> running on the node via the ps command.  When I try to use the pvm shell 

> on that node, it displays a notice that the pvmd is already running and 
> hangs till I kill the process.  Any clues or suggestions ?

Well problem solved ... writing this so it is in the list archives.

It turns out the the machine name was listed twice in /etc/hosts, first as 
the loopack and second under it's eth0 address.  Someone smarter than me 
well need to explain this, but rsh and ssh picked the eth0 address, so I 
was able to connect to the remote machine, but the pvmd was using the 
loopback address.

Thank you for all your suggestions.

Jim Parker

Sailboat racing is not a matter of life and death ....  It is far more 
important than that !!!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.beowulf.org/pipermail/beowulf/attachments/20010501/9fb7c64c/attachment.html>

More information about the Beowulf mailing list