3c905B-TX on ASUS P2B board no working

Kevin Cameron dkc@grfx.com
Thu Jul 30 05:02:49 1998

Sounds like the problem I had - the interrupt for the 3C905 was being shared
(see the FAQ). My machine is dual-bootable with Windows 95 - I just played
with the BIOS settings for the interrupts until the card got its own (the W-95
system/device manager shows what's assigned too). Then it all worked fine.


ASUS-TX97E + 2940UW + 3C905 + NCR-SCSI + USR Winmodem
                              + Diamond 3d 3000 + SoundBlaster

Chen Chi Ming Hubert wrote:

> Hi.  I have a 3c905B-TX on an ASUS P2B motherboard.  I just installed
> RedHat 5.1 (kernel 2.0.34), with Mr Donald Becker's 3c59x.c driver written
> on 12th May, 1998.  However, the ethernet card does not seem to be working.
> I have solved the ff:ff:ff:ff:ff:ff station address problem by disabling the
> PnP OS setting in the BIOS setup, and cold booting, but the problem persists.
> ifconfig now gives:
> eth0    Link encap:Ethernet  HWaddr 00:10:4B:CD:0A:64
>         inet addr: <my IP addr>  Bcast: <broadcast addr>  Mask: <subnetmask>
>         UP  BROADCAST  RUNNING  MULTICAST  MTU:1500  Metric:1
>         RX packets:0  errors:0  dropped:0  overruns:0
>         TX packets:2  errors:0  dropped:0  overruns:0
>         Interrupt:9  Base address:0xd000
> /proc/interrupts also shows the ethernet card on IRQ 9.
> On the other hand, just before the LILO prompt appears, a 'PCI devices listing'
> indicates that both the 'Serial bus controller' and the 'Network controller'
> are on IRQ 9.  So, I suspected that it is an IRQ conflict, but the kernel
> ignores command line options such as 'LILO: linux ether=3,0,eth0' and keeps the
> ethernet card on IRQ 9.  Pinging other machines results in 100% packet loss.
> There is also an Adaptec 2940 SCSI controller on the same machine, on IRQ 10,
> in case that is relevant.  Does anyone know of a solution to this problem?  Any
> help will be much appreciated.
> -- Hubert Chen  23:51  29- 7-1998