3C905B problems

Jerry Sweet jsweet=linux-vortex-bug@irvine.com
Tue Jul 21 10:12:21 1998

Here's some information about a similar configuration that _might_
help you with your 3C905B problem.

- My working configuration:

I was able to get 3C905B-TX cards working in ASUS P2B and P2B-DS
motherboards with Red Hat 5.1 using the CESDIS 0.99E driver.  

These ASUS motherboards use the BX chipset and have 400MHz Pentium II
processors installed.  The P2B is a single-CPU mobo; the P2B-DS is a
dual-CPU mobo.

Two 3C905B cards are installed per system--one connected to a 10Mb
network, the other to a 100Mb network.  No DOS-based pre-configuration
of the 3C905B cards was necessary for me; the default auto-select
behavior worked fine.

- My previous non-working configuration:

I was _not_ able to get the same 3c905B cards working in SuperMicro
P6DBE or P6SBA motherboards, but this might have been because our
particular motherboards had other problems.  We exchanged these
SuperMicro mobos for the aformentioned ASUS mobos.

- My configuration problem and resolution story:

The 3C905B cards worked immediately in the ASUS P2B-DS, but in the
ASUS P2B the 3C905B cards appeared to have problems working together.

The symptoms were identical to those you described: both cards
were detected correctly and displayed the correct hardware address,
but there was no network connection--nothing would ping.

With just the one 10Mb-connected card installed (eth0), the 10Mb
network connection worked fine; with the second card installed (eth1),
neither card worked.  Un-configuring the eth1 interface and rebooting
didn't help.

Then I discovered that the second card had a bad connection to the
100Mb network.  The problem was traced to a bad wall port.  After
bypassing the wall port, thus establishing a good connection to the
100Mb network, both cards worked correctly.

So, strangely, the second card had to be operating correctly in order
for either one to work.

- Conclusion:

The moral of this story is: it could be the motherboard (although ASUS
is tops with me right now) or it could be the physical network

Other possibilities:

- The Award BIOS on ASUS mobos doesn't necessarily report usage
  of IRQ 12 by a PS/2 mouse.  In my case, even with a mouse
  on the PS/2 mouse port, the BIOS blithely assigned IRQ 12 to
  one of the 3C905B cards.

  So, if you're using the PS/2 mouse port, then you _might_ have an
  IRQ conflict if the initial boot-up message shows a network
  interface adapter on IRQ 12.

  I switched the mouse to COM1 to make certain, but I didn't
  experiment further once the 3C905B cards were working.

  On ASUS mobos, the list of IRQs used by PCI boards is reported just
  before the LILO prompt on a video console.

  (Wouldn't it be nice if there were some way to get the
  definitive, guaranteed comprehensive list of what devices are using
  which IRQs, all in one place?)

- If you installed or booted Microsoft Windows just before booting
  Linux, you might want to power-down the system before booting
  Linux.  This incantation has been recommended to me; it might
  work for you.

The problem that you report with "netstat -r" hanging occurs because
you have /etc/resolv.conf pointing to external name servers that
cannot be reached.  Use "netstat -rn" to see the complete routing
table in numerical format (bypassing reverse name resolution).