linux 3c59x driver

Leon Avery
Wed Jul 8 11:09:31 1998

I am the administrator of a brand new Red Hat linux 5.1 PC with a
brand new 3C905b enet card.  I downloaded the lastest 3c59x.c driver
source (the version string is "3c59x.c:v0.99E 5/12/98 Donald Becker") and compiled
it without trouble.  The card is properly detected on boot as a
cyclone.  However, it doesn't work -- I have the ff:ff:ff:ff:ff:ff
address problem.  According to the "Using Linux Network Device Drivers
as Modules" page,

    The solution is to either update to the latest driver, (the
    drivers are being re-worked to enabled the devices) or to disable
    the "PnP OS" setting in the machine's BIOS setup.

As far as I know, I have the latest driver (though I'd be happy to
learn that I'm wrong).  I've tried PnP OS both ways (it was originally
off, actually), and it makes no difference.

Any help would be greatly appreciated.

Leon Avery                                       (214) 648-4931 (voice)
Department of Molecular Biology and Oncology              -1488 (fax)
University of Texas Southwestern Medical Center
5323 Harry Hines Blvd                  
Dallas, TX  75235-9148