[scyld-users] bpsh in background: defunct processes

Anand Bedekar anandbedekar at yahoo.com
Mon Sep 29 18:06:02 PDT 2003


I'm trying to run bpsh in a script that calls bpsh in
a loop, like this:

for i in 1 2 3
    bpsh -n $i run.sh &

The script run.sh is another script that runs a
simulation program (does not issue further calls to
bpsh, just runs an executable and then some awk/perl
for post-processing). The intention is to run an
instance 'run.sh' on each of the nodes in the list
that 'for i in...' loops over.

What happens is that all the processes called within
run.sh seem to go into a "defunct" state without
finishing cleanly. This is making the process table
fill up, so that no more processes can be run. 

Is this usual behaviour when calling bpsh to run a
shell script, given the way I am calling 
'bpsh -n $i run.sh &' ? Is there some other way to run

Unfortunately all the nodes in the cluster are
currently out of action because the process table is
full on all of them, due to the above. So I can't
report on which version of scyld has been installed,
until the sysadmin reboots the whole thing. I do know
the machines are P3 running RedHat 7.0, kernel version

Any help would be appreciated.


Do you Yahoo!?
The New Yahoo! Shopping - with improved product search

More information about the Scyld-users mailing list