[scyld-users] e1000 and Scyld 28cz

Wade Hampton wade.hampton at nsc1.net
Tue Sep 2 14:13:01 PDT 2003


I'm upgrading my first test cluster to 1G ethernet
using the onboard e1000 parts on my nodes (Tyan
motherboards with eepro100 and e1000). 

I have not gotten the nodes to boot and recognize
the e1000 cards using a beoboot floppy. 

When I tried the latest driver from Intel (5.1.13),
I could not get an e1000 module for my node boot
floppy until I did the following:

    make KCFLAGS="-D__BOOT_KERNEL_H_ -D__module__beoboot
    mv e1000.o /lib/modules/2.2.19-14.beobeoboot/net

I also added the following to /etc/beowulf/config
    pci   0x8086   0x1008   e1000


When I try to boot this floppy, it stopped booting after loading the
e1000 driver and appeared to hang.

I then removed the e1000.o modules and tried the Scyld RPM
for 4.4.12.   This seemed to hang at the same location.

Any help in this matter would be appreciated.
Wade Hampton

More information about the Scyld-users mailing list