SMP support with the scyld package

Carpenter, Dean Dean.Carpenter at
Tue Mar 27 13:27:22 PST 2001

OK, I think I've answered one or two of my own questions here ... but there
are still issues.

/var/beowulf/boot.img is the netboot'd kernel, taken from the -k parameter
to beoboot.  The phase 1 kernel boots this image.  No problem - I got it :)
Doh - it was late, I was tired - that's it.

1st problem :
This appears to be with the smp kernel package.  It won't boot on the master
node.  I install the rpm with the command show below, and it appears to go
fine.  The files are all there, including the /lib/modules/2.2.17-33.beosmp.

	rpm -i kernel-smp-2.2.17-33.beo.i686.rpm

I adjust the master node thus :

/boot/vmlinuz -> /boot/vmlinuz-2.2.17-33.beosmp
/boot/ -> /boot/
/boot/modules-info -> /boot/module-info-2.2.17-33.beosmp (actually same as
.beo one)

Add a new entry to /etc/lilo.conf for the smp kernel, and reboot the master
node.  It starts to come up, tried to load the aic7xxx module which has tons
of unknown symbols and fails, so the root fs fails to mount, and it dies.
It was trying to load from /lib/aic7xxx.o - weird location ...

2nd problem :
For the hell of it, I tried to build a new kernel.  I copied
/usr/src/linux-2.2.17 away to save it, then copied
configs/kernel-2.2.17-i686-smp.config to .config and ran :

make clean
make dep
make bzImage  which fails with :

scripts/split-include include/linux/autoconf.h include/config
find: *: No such file or directory
scripts/split-include: find - pclose: Success		<<<<--- see below
make: *** [include/config/MARKER] Error 1

I added the " - pclose" to the split-include.c file at the very end to
verify where the error was being thrown.

3rd problem : (actually, from original question below, partially solved)
In any case, I try to create a phase 2 boot image using the smp kernel from
the rpm on the CD.  My original beoboot -2 from the earlier post failed
because the nodes tried to load modules from /lib/modules/2.2.17-33.beo.
That was my fimble fungers there - I used -m /lib/modules/2.2.17.beosmp -
forgot the -33 in there.  This is the one that almost works :

	beoboot -d -2 -n -k /boot/vmlinuz-2.2.17-33.beosmp -m

The node comes up, but fails because /dev/bproc doesn't exist :(  So it
looks like BProc wasn't integrated properly in the rpm ?  I found bproc.o in
/lib/modules/2.2.17-33.beo/misc, but it wasn't in the
/lib/modules/2.2.17-33.beosmp/misc dir.  Hrm.  rpm -qf bproc.o doesn't know
anything about it either - no package appears to own it.  It doesn't show up
in the list of files via rpm -ql for the standard kernel-2.2.17-33.beo or
the kernel-smp-2.2.17-33.beo.

Oh well.  Copy the bproc.o file to the smp modules tree.  Rebuild the boot
image with the beoboot -2 command as listed above.  Sure enough - bproc.o is
now listed in the debug output.  Reboot a dual-cpu node to see if it takes

Nope.  bpsh 10 uname -r still shows 2.2.17-33.beo as the kernel.  Dang.


Given a raw Scyld install, can anyone show a cookbook sequence to converting
the master node as well as the slave nodes to a custom kernel ?  Not just
the SMP kernel from the rpm - we'll want to play with MOSIX, as well as the
2.2.19 kernel.

1. Install x and y packages to solve problem #2 above so we can actually
build kernels.
2. Pull down virgin kernel sources and untar into /usr/src/linux
3. Integrate the bproc patches .....  (how - what else ?)
4. Integrate MOSIX (and any other cool) patches
5. Build the kernel and modules (any special considerations ?)
6. Build the custom phase 2 boot image
7. Rock and roll :)

Dean Carpenter
Principal Architect
Purdue Pharma
dean.carpenter at
deano at
94TT :)

-----Original Message-----
From: Carpenter, Dean [mailto:Dean.Carpenter at]
Sent: Monday, March 26, 2001 5:06 PM
To: 'Jag'
Cc: 'beowulf at'
Subject: RE: SMP support with the scyld package

Ah ha.  OK, I found that on the CD, and installed it

	rpm -i kernel-smp-2.2.17-33.beo.i686.rpm

No problem, and I see the new kernel in /boot and the modules in

So I change /boot/vmlinuz to point to the new kernel, and then create the
netboot image ...

	beoboot -d -2 -n -k /boot/vmlinuz-2.2.17-33.beosmp -m

That chews for a little while, and the debug output looks OK.  I noticed
that it recreated the /var/beowulf/boot.img file though ...  Why ?

In any case, I reboot on of the dual nodes with the *existing* boot floppy
(created last week from beosetup gui) and it appears to come up OK, but not
all the way.  The log shows that it's still trying to use the UP modules in

Dang.  I thought the phase 1 kernel on the floppy was a generic one (from
/boot/vmlinuz.beoboot, which is just a symlink to
vmlinuz-2.2.17-33.beobeoboot :) just to get to the master node to boot the
"real" kernel - the smp one just installed.  Hmmm, OK, recreate the floppy
from the gui.  I don't think it should be different, but just in case.

This is worse.  It dies while loading vmlinuz, asking for another boot disk.

Ah ha (again).  I just noticed module-info in /boot, pointing to the UP
modules-info-2.2.17-33.beo file rather than the smp one.  I just changed
that and rebooted a couple of the dual nodes.  We'll see.

Nope.  Systems booted from the old floppy still try to use the UP modules in

So where exactly do all the kernels fit in ?

/boot/vmlinuz-2.2.17-33.beobeoboot	aka vmlinuz.beoboot
/var/beowulf/boot.img			What's the connection between these
for the floppy ?

Sorry for being thick here ...

Dean Carpenter
Principal Architect
Purdue Pharma
dean.carpenter at
deano at
94TT :)

-----Original Message-----
From: Jag [mailto:agrajag at]
Sent: Monday, March 26, 2001 3:22 PM
To: Carpenter, Dean
Cc: 'beowulf at'
Subject: Re: SMP support with the scyld package

On Mon, 26 Mar 2001, Carpenter, Dean wrote:

> Hummm.  I see that it ships with the 2.2.17 sources, but I don't see any
> kernels lying around ...

It's in the kernel-smp package.

Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list