NIS/YP on RH7.1

Georgia Southern Beowulf Cluster Project gscluster at
Wed Jun 6 14:14:39 PDT 2001


Since many of us manage quite large networks I believe it appropriate to ask 
question about NIS/YP here.  I've used RH6.2 and managed NIS quite 
successfully, but now I am at a loss.  The software in RH7.1 is a bit 
different from that of 6.2 and seems to behave differently as well.

My basic problem is I have 8 seperate cluster networks that are also 
connected together by a ninth network (dubbed .treenet), a basic tree 
topology.  A seperate server on the interconnecting network is the NIS 
master and is the only machine where I directly edit user configurations.  
Now my 8 other servers are NIS slave servers and serve NIS requests to their 
respective cluster networks.  All of this is in one domain, say . . . 
cluster.nis.  Now as I add, delete, and modify user accounts on the master 
machine the changes do not progress to the slave servers.  I've tried to run 
/usr/lib/yp/ypinit -m on the master and /usr/lib/yp/ypinit -s master.treenet 
on the slaves, but the slaves give me an error: "Can't enumerate maps from 
ga. Please check that it is running."  I cannot get these maps to migrate, 
with the exception of running the /usr/lib/yp/ypxfr_1perday and such 
scripts, but this is not convenient as I wish these changes to migrate NOW!  
This all worked in RH6.2, but it does not seem to work in RH7.1.

Also, ypbind is working, I have cluster nodes looking to their server (a NIS 
slave server) and the slave servers look to themselves.  This sounds logical 
to me since the slaves will update when the master pushes new maps.

I've also read the NIS/YP HOWTO, but nothing seems to work.  Maybe some of 
you know the answers or can give me pointers.  This is the only thing 
keeping me from opening these machines to users.

Thank you,

Wesley Wells
NIST Beowulf System
Get your FREE download of MSN Explorer at

More information about the Beowulf mailing list