[tulip] Re: Failed to map PCI address ? (Problem solved!)

Fred Wilson Horch fhorch@ecoaccess.org
Sat, 08 Jul 2000 21:01:13 -0400

On Sat, Jul 08, 2000, Philipp Schulte wrote:

>> Does anyone know what 'Failed to map PCI address' means?
>I don't know what it means but I know how to avoid it :)
>I had this problemsome time ago and Mr. Becker told me to do this:
>Compile tulip.c v92 with the *additional* flag '-DUSE_IO_OPS'

Wow, that's impressive -- worked like a charm!

I recompiled tulip.c with this command:

gcc -DMODULE -DUSE_IO_OPS -Wall -Wstrict-prototypes -O6 -c tulip.c

Then I was able to modprobe tulip, and bring up the interface.  We are
in business!


Now, what did I just do?  ;-)

/proc/ioports shows

ec80-ecff : eth1
ef40-ef5f : Intel Speedo3 Ethernet

/proc/interrupts shows
 9:         25   eth1
10:     223900   Intel EtherExpress Pro 10/100 Ethernet

I see the comment in the source of tulip.c:

/* This driver was originally written to use I/O space access, but now
   uses memory space by default. Override this this with -DUSE_IO_OPS.

Is there any practical difference between the two (I/O space access vs.
memory space access), aside from the obvious (i.e., that memory space
doesn't work for me)?  Why was the driver rewritten to use memory space
by default?
Fred Wilson Horch			mailto:fhorch@ecoaccess.org
Executive Director, EcoAccess		http://ecoaccess.org/
2408 Prince St, Durham, NC 27707	phone: 919.419-8354