[netdrivers] linux starfire network driver

Paul Check paul at openstreet.com
Tue Apr 5 22:23:18 PDT 2005

Has there been any follow up on this? So far I've not been able to get 
the driver workin witn my 2.6.11 kernel. Is it not functioning with 2.6, 
or is this just a case of config?

Regards, Paul

>> More problematic is that there are no network connections possible
>> the card running under a 2.6 kernel. That card runs okay under linux
>> 2.4.26. I tried with kernel 2.6.7 and 2.6.8-rc2. I also tried with
>> acpi=off, noapic, pci=noacpi, pci=biosirq. Nothing worked.
>> And yes: Routing is configured correctly, Firewall is down. Ifconfig
>> shows running interfaces, /proc/interrupts shows the interfaces.
>> I tried to compile the module with the following options
>> enabled/disabled:
>> A friend of mine with a complete different system and kernel config
>> (board, SMP) tried a while ago with kernels 2.6.0 and 2.6.5
>> independently of me and had the same problem too.
>Has there been any resolution for this?? I have exactly the same
>including the message:   
>		Something wicked happened! 0x02018101.
>		Something wicked happened! 0x02010001.
>Which seems to be error bits in the interrupt status that the driver

>Any more recent driver?? I pulled the file from the scyld.com web page..
>It's listed as version 1.09, but is clearly a 2.4 kernel driver. The
>version that came with SuSE Linux Pro 9.1 compiles cleanly under 2.6.4
>of the kernel, and yet claims to be 1.03 of starfire.c.. Perhaps that's
>just the version SuSE ported to 2.6... In any case neither works.. Any
>word on working 2.6.4 et al drivers for the Adaptec ANA-64044LV card
>(quad 10/100 card with 1 AIC-6915P device per port).
>-Charlie D.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.scyld.com/pipermail/netdrivers/attachments/20050406/e83bfe69/attachment.html

More information about the netdrivers mailing list