[Beowulf] Re: [OT: LTO Ultrium (3) throughput?

David Mathog mathog at caltech.edu
Wed Jun 18 17:56:43 PDT 2008

Joe Landman wrote:

> Have you adjusted the block size up?  maybe try
> dd if=/dev/zero of=/dev/nst0 bs=8M count=1000

The tape has a 64Mb on board buffer and somewhere in the manual it said
that it shouldn't matter.  But no, I have not tried that yet and will
do so tomorrow.

> This said, have you tried the "obvious" tests, such as what does lsscsi 
> report, and lscpi -v for that adapter, and ...

Maybe it will mean more to you than it does to me...

% lsscsi --long
[8:0:0:0]    tape    HP       Ultrium 3-SCSI   D21D  /dev/st0
  state=running queue_depth=32 scsi_level=4 type=1 device_blocked=0

lspci -v 
04:04.0 SCSI storage controller: Adaptec ASC-29320ALP U320 (rev 10)
	Subsystem: Adaptec ASC-29320LPE PCIe U320
	Flags: bus master, 66MHz, slow devsel, latency 32, IRQ 19
	I/O ports at 4400 [disabled] [size=256]
	Memory at d8400000 (64-bit, non-prefetchable) [size=8K]
	I/O ports at 4000 [disabled] [size=256]
	[virtual] Expansion ROM at d8600000 [disabled] [size=512K]
	Capabilities: [dc] Power Management version 2
	Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1
	Capabilities: [94] PCI-X non-bridge device

/proc/interrupts shows that this controller is the only thing on
IRQ 19.


David Mathog
mathog at caltech.edu
Manager, Sequence Analysis Facility, Biology Division, Caltech

More information about the Beowulf mailing list