[Beowulf] WOL on nforce4 mobo under linux?

David Mathog mathog at caltech.edu
Wed May 17 12:50:20 PDT 2006

Have any of you managed to get WOL working for an nforce4 mobo 
running a recent linux kernel?

On an A8N5X (nforce4, not ultra) motherboard WOL works fine if
the machine shuts down from XP.  So the BIOS and hardware are
clearly set up correctly.  However on "poweroff" from linux
( using the forcedeth driver) it won't wake up from
a magic packet.  The ethernet card light stays on though, and
it blinks as packets go by, so it should be able to respond to the packet.

Things I've tried so far:

1.  ethtool -s eth0 wol g
    ethtool eth0 (verifies that wake-on is set to g)
2.  modify /etc/rc.d/init.d/halt
    remove the "-i" option off the final /sbin/halt call
3.  google, a lot
4.  tried to install the nvidia "nvnet" driver - except it
    blew up when trying to build the driver.
    This was the x86 version, not the 64 version.
    Apparently nvnet doesn't get along with this
    kernel version.

The kernel starts with only: append="resume=/dev/hda3 splash=silent",
acpi seems to be used (judging from the dmesg entries) and acpid is up.
It did strike me as odd that in /proc/acpi/wakeup there
seems not to be a device corresponding to the network card.
I tried changing the settings of everything in there to "enable"
and it didn't help, still a magic packet sent to the machine
following a "poweroff" did not wake it.

Any ideas?


David Mathog
mathog at caltech.edu
Manager, Sequence Analysis Facility, Biology Division, Caltech

More information about the Beowulf mailing list