[Beowulf] wrf + mpich p4 problem with vanilla kernels

Dimitris Zilaskos dzila at tassadar.physics.auth.gr
Sun Apr 2 09:57:36 PDT 2006

 	Hi all,

 	I am trying to run WRF model on a dual core dual cpu opteron system with 
intel c/fortran 9 , scientific linux (rhel compatible, tried 3.0.4 , 3.0.5 
, 4.2) and mpich 1.2.7p1. As long as I use the vendor supplied kernels 
everything works fine. However , when I use kernels compiled on my own, I 
am getting erratic behaviour: the model will either crash, or produce 
invalid results, or complete successfully approximately once in 20 
attemps. If I run it on one CPU it completes successfully with all 
 	I have tried with, and 2.6.9. Both show the same 
erratic behaviour. Kernels 2.6.9-22 and 2.6.9-34 as supplied by scientific 
linux 4.2 work fine, as well as 2.4.21-37.0.1 in 3.0.4. All kernels are 
smp enabled.

 	Any help is appreciated.

 	Best regards,

Dimitris Zilaskos

Department of Physics @ Aristotle University of Thessaloniki , Greece
PGP key : http://tassadar.physics.auth.gr/~dzila/pgp_public_key.asc
MD5sum  : de2bd8f73d545f0e4caf3096894ad83f  pgp_public_key.asc

More information about the Beowulf mailing list