[Beowulf] problems to compile mpich2 with Intel compiler

Ted Sariyski tsariysk at craft-tech.com
Thu May 26 09:11:58 PDT 2005

I have real difficulties to run my code with mpich2-1.0.1 (the latest) 
compiled with ifort. I am able to compile mpich2 and to run the tests in 
examples directory but when I run my code  I get errors.

I run i386 GNU/Linux box/w RedHat EL4 with kernel 2.6.9-5.0.5
Intel(R) Fortran Compiler for 32-bit applications, Version 8.1    Build 
20041118Z Package ID: l_fc_pc_8.1.023

Here is what I do. I configure mpich2 with following arguments:

export FC=ifort
export F90=ifort
export F90LIB=-static-libcxa
export FLIB=-static-libcxa
export F90LIBS=-static-libcxa
export FLIBS=-static-libcxa
./configure --prefix=/usr/local/mpich2-1.0.1_if --enable-f77 
--enable-f90 --enable-romio --enable-threads=no

I compile my application without errors or warning but at run time I get 

$  ./mycode_ifort
$  aborting job:
Fatal error in MPI_Comm_rank: Invalid communicator, error stack:
MPI_Comm_rank(105): MPI_Comm_rank(comm=0x5b, rank=0x8466c48) failed
MPI_Comm_rank(64): Invalid communicator
rank 0 in job 4  craft99_36065   caused collective abort of all ranks
  exit status of rank 0: killed by signal 9

The same code but mpich2 compiled with g95 returns:

$  ./mycode_g95
Process  0  of  1  is alive
./mycode_g95 called with  0 arguments!
USAGE: ...

What do I miss here? Any help will be highly appreciated.
Thanks, Ted

More information about the Beowulf mailing list