[Beowulf] problem compiling mpich2 with pgf90

Ted Sariyski tsariysk at craft-tech.com
Thu May 26 07:38:03 PDT 2005

I have been compiling mpich-1.2.x with pgf90 dozens of times but I have
real difficulties to compile mpich2-1.0.1 (the latest) with pgf90 (I
tried v.6 and v.5.2-4). Here is what I do (output from configure and from make are attached; I run i386 GNU/Linux box/w RedHat EL4 with kernel 2.6.9-5.0.5)

export FC=pgf90
export F90=pgf90
export CC=pgcc
export CXX=pgCC
export F90LIB="-L${PGI}/linux86/current/lib -lpgf90 -lpgf90rtl
-lpgftnrtl -lpgc"
export FLIB"-L${PGI}/linux86/current/lib -lpgf90 -lpgf90rtl -lpgftnrtl
export CFLAGS="-Msignextend -tp px -DUSE_U_INT_FOR_XDR
export FFLAGS="-tp px"
export F90FLAGS="-tp px"
export CXXFLAGS="-tp px"
./configure --prefix=/usr/local/mpich2-1.0.1_pgi --enable-f77
--enable-f90 --enable-romio --enable-threads=no

#> make
../bin/mpicc  -I../src/include -I../src/include -tp px
../bin/mpicc -L../lib -o cpi cpi.o  -lm -lmpich       -lpthread  -lrt
       -lpthread  -lrt
/root/DIST/mpich2-1.0.1/lib/libmpich.a(setbotf.o)(.data+0x0): undefined
reference to `pgf90_compiled'
make[1]: *** [cpi] Error 2
make: *** [all-redirect] Error 2

Any help will be highly appreciated.
Thanks in advance, ted

More information about the Beowulf mailing list