[Beowulf] kickstart install using NFS

Pat Delaney Pat.Delaney at inewsroom.com
Fri Jan 7 13:36:40 PST 2005

Did you ever get an answer to your post??  I'm trying to do the same
I'm preparing to install a large number of new nodes using redhat and
planned on using the kickstart option.  I have gotten a kickstart file
just the way I want it with one exception and I can not get it to work.
ultimately want to boot from a floppy and in the kickstart file tell it
get the rpm's from a nfs mount.

So far I have:

1.)  Booted from a cd and issued the command:
linux ks=floppy
This is how I built and debugged my ks file.  This gives me what I want,
except I get to swap CD's during the install.  No nfs option at this

2.)  I added the line
nfs --server=my.local.server.com --dir=/redhat
and tried the 'linux ks=floppy' again booting from the CD.  It continues
get the rpms from the CD.

3.)  I built a floppy from mkbootdisk, with the ks.cfg file and at the
prompt typed linux ks=floppy.  This time it went directly to the resuce
from the HD.

4.)  I then got a recommendation from someone to modify the syslinux.cfg
file on the floppy.  I tried that and got errors like the following:

mount: error 22 mounting ext2
pviotroot: .{stuff deleted} failed: 2
Kernel panic: No init found.  Try passing init= ...

5.)  I've built the system with the CD and my kickstart and made sure I
could mount my nfs box and directory once everything was up and I could.
I've given just about everyone premission to the directory and the

I've looked through all the kickstart how-to's, the redhat references
can't find anything wrong.

Here is the relevant part of the ks file:

lang en_US
langsupport --default en_US.iso885915 en_US.iso885915
keyboard us
mouse generic3ps/2 --device psaux
rootpw --iscrypted blahblahblah
firewall --disabled
authconfig --enableshadow --enablemd5
timezone America/Chicago
network --bootproto dhcp
nfs --server=myserver.name.com --dir=/redhat/RedHat
bootloader --location=mbr
clearpart --all
zerombr yes
part / --fstype ext3 --size 5120
part /home --fstype ext3 --size 1024
part swap --size 1024
part /scratch --fstype ext3 --size 1024 --grow

The directory tree on the remote machine is:

'-- RedHat
    |-- RPMS
    '-- base

Are the ks commands echo'd to a file so I can see what is happening, or
there are any errors?  I've looked at the anaconda-ks.cfg file and it is
very close replica of my ks.cfg file, with the glaring exception of the
command, and some post install stuff.

Thanks in advance for any and all help or suggestions.


*	Previous message: Anyone have information on latest LSU beowulf?
*	Next message: kickstart install using NFS
*	Messages sorted by: [ date ]
<http://www.scyld.com/pipermail/beowulf/2002-October/date.html#8245>  [
thread ]
[ subject ]
[ author ]


More information about the Beowulf mailing list

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.beowulf.org/pipermail/beowulf/attachments/20050107/890b0c2d/attachment.html>

More information about the Beowulf mailing list