MPICH 1.2.5 and PVFS Problem

Kumaran Rajaram kums at CS.MsState.EDU
Mon Jan 20 14:08:40 PST 2003


Try configuring mpich using the following option:
./configure -opt=-O -device=ch_p4 --with-romio="-file_system=pvfs+ufs+nfs"
-lib="-L/usr/lib/libpvfs.a -lpvfs" -cflags="-I/usr/include/pvfs"


-- Kumaran Rajaram, Mississippi State University --
kums at  <>

On Mon, 20 Jan 2003, Aaron Collier wrote:

> Hello,
> I have been having problems getting MPICH 1.2.5 to compile with ROMIO
> support for PVFS.  I have installed PVFS and used the -cflags argument to
> pass the location of the PVFS include files, but I still get errors.  From
> what I can tell the problem isn't with ROMIO, but rather with MPICH.  I
> checked and ROMIO compiles all of the files properly with the added
> include argument, but MPICH complains about the library file (libmpich.a).
> The error messages I get complain about unknown references (the function
> prototypes it needs are in the include files I provided an argument for).
> What am I doing wrong?  MPICH compiles without any errors when I specify
> that ROMIO only support nfs, but I really need PVFS to work as well.  I
> even tried compiling ROMIO seperately, but the Makefile included with the
> source distribution has some syntax problems.  I also had to add a few
> includes to numerous files to get them to compile properly.  Even then I
> couldn't get ROMIO to install properly.  Has anyone configured MPICH with
> ROMIO support for PVFS?  Any help anyone could provide would be greatly
> appreciated.
> Bye,
> Aaron
> _______________________________________________
> Beowulf mailing list, Beowulf at
> To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list