Gaussian installation on Athlon XP 2000

Velocet math at
Mon Sep 23 14:36:06 PDT 2002

On Mon, Sep 23, 2002 at 01:06:57PM -0500, Sai Ganesh Ramesh's all...
> Hello,
> 	I'm a graduate student at UW-Madison in the US. Sorry for
> bothering you but my lab has new Athlon machines on which we want to get
> Gaussian 98 running in the Linux mode. I've got the ATLAS program to get
> the tuned BLAS libraries out of but for some reason things seem to be
> failing at one stage or another. I found your posting on the site
> and thought you might be able to help.
> 	The ATLAS library on one of the machines compiles and gives me the
> files libatlas.a, libstatlas.a, libcblas.a, libf77blas.a, liblapack.a
> which I take as being the tuned libraries needed for G98 installation. I
> put these files in the appropriate directory. Our systems expert helped
> with manupilating the script so that G98 executables get compiled (pgf77
> is available). That worked but now when I try to run test jobs g98
> complains saying '.../l1.exe relocation error : .../ undefined
> symbol s_wsfe'. I tried to use grep to find subroutines/files with that
> name somewhere but that resulted in not finding it anywhere in the g98 or
> ATLAS installation directory. The deal with another Athlon machine is
> that it won't compile the tuned libraries themselves and the machine just
> shuts down somewhere in between. I probably shouldn't try that again for
> fun. I'm really stuck here and would be glad to have any bit of help from
> you. I'm not conversant with Linux system administration. So if there is
> something complication to be done please break it down as best as you can.
> Again, sorry about bothering you but I really need some advice.

You need to link the libraries in the right order as it says in the docs on
compiling g98, and you need to set your LD_LIBRARY_PATH (or
LD_LIBRARY_PRELOAD) correctly to load from that directory where it was

Here's what I use:

ld -shared -o dummy.o --whole-archive util.a --no-whole-archive \
$ATLASLIBS/libtstatlas.a $ATLASLIBS/libf77blas.a $ATLASLIBS/libatlas.a

Actually I made a script because I kee because I keep building it with atlas
on whatever different platforms we come across. However, recompiling ATLAS on
each different platform seems to make no diff, in fact, ATLAS and G98 compiled
on linux on the same hardware, then run in FreeBSDs linux mode is the same
speed as compiled natively. Furthermore, compiling on one athlon platform
seems to be the same speed as any other athlon platform. (I havent tried P6 or
P7 architecture ATLAS on athlon or vice versa I dont think, I dont expect it
to work correctly however).


> Regards
> Sai
> _______________________________________________
> Beowulf mailing list, Beowulf at
> To change your subscription (digest mode or unsubscribe) visit

Ken Chase, math at  *  Velocet Communications Inc.  *  Toronto, CANADA 

More information about the Beowulf mailing list