Tyan serial console - how?

Ken Chase math at velocet.ca
Tue Nov 5 12:53:53 PST 2002

On Tue, Nov 05, 2002 at 12:36:51PM -0800, David Mathog's all...
> I've been trying to get the Tyan serial console working
> on our rack full of 2466 boards. So far only partial success.
> I've tried this:
> In the BIOS in the serial console section on node A set to:
> on Board ComA, direct, 115200, none, vt100, on
> In kermit on node B (linux) which will connect to A:
> set line /dev/ttyS0
> set speed 115200
> set flow none
> set watch-carrier off
> connect
> Connect Com A of node A to Com A of node B with a null modem
> cable (6ft).
> Boot node A.
> Node A comes up, there's a quick flash in the kermit window,
> and it goes on to lilo/linux.  On the monitor also plugged into it
> I can see that the quick flash corresponds to the first screen
> of the boot sequence.  It was possible to get into BIOS setup by
> tapping F2 continuously on  node A's keyboard from reset or
> power up.  (By the time anything shows up on A's monitor it's
> always too late to hit F2 :-(.)  I've tried hitting the "F2" key
> in node B's kermit window, but the boot process ignores that and
> goes right on to lilo and linux.
> What must be typed in the serial console to break into the BIOS?

I had massive problems playing with the serial console on linux at
anything higher than 9600. Having no flow control is good, but more
and more dangerous at higher bitrates. You are expecting no errors.
Remember the screen is being repainted raster style from top to bottom
in a sweep - like a tv's electron gun. At 115Kbps it might look like
'snow' as the errors appear for certain letters here and there and
are corrected on the next sweep.

Go back to 9600 and try again.

Also I found that the boards really didnt like certain serial cables
and I couldnt send characters INTO the boards, but got output no 
problem. Very odd.

I have never seen serial console from the BIOS work past the linux boot,
at which point it goes from 'raster sweep refresh' to a regular serial
console. Of course this only works because I compiled in serial console
support into the OS (at 9600 obviously).


> Once in the bios there are squares (single letter size "pixels")
> dancing around the screen like "snow" on a TV.  Presumably the
> serial line protocol isn't set up quite right.  What should it
> have been?
> Is it possible to use the serial console to break into a 
> Tyan node which has locked up in linux?  By this, I mean
> something similar to the Sun console or the VMS console,
> where you can get in "underneath" the OS and force a
> reboot without having to cycle the power or hit the reset switch.
> Thanks,
> David Mathog
> mathog at caltech.edu
> Manager, Sequence Analysis Facility, Biology Division, Caltech
> _______________________________________________
> Beowulf mailing list, Beowulf at beowulf.org
> To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

Ken Chase, math at velocet.ca  *  Velocet Communications Inc.  *  Toronto, CANADA 

More information about the Beowulf mailing list