Advice on Cluster Hardware.

Andrew Shewmaker shewa at
Wed Feb 6 15:42:58 PST 2002

I can verify that the idex=ata66 option helps with a 2.4.16 kernel (a 
value of ata100 is not valid).  hdparm -i /dev/hdc shows that these 
options change the DMA mode from udma2 to udma4.  It doesn't look like 
the change in linux/drivers/ide/ide.c of 2.4.18-pre3 would fix 
autodetection of an 80 wire cable.  There was no change in 

There was a patch against 2.4.10 that should fix autodetection and 
perhaps enable udma5 mode.  I haven't tried it yet.


Donald B. Kinghorn wrote:

> You can take care of this by adding ide0=ata66 ide1=ata66 to the Lilo append 
> line. It forces the udma mode 5 bit and seems to work fine (you get full mode 
> 5 so you don't need to use ide=ata100 although that may work to ??). I've 
> been doing this for several months now on Tyan boards and haven't had any 
> problems ... I found this by reading the kernel ide source code ... use the 
> source Luke ...
> I think there are some other ways to take care of it too, like a kernel patch 
> or tweaking things in a custom kernel build ...
> -Don
> I've tried the AUSU dual athlon and yes there do seem to be some problems. 
> The first is that 2 out of 3 were DOA ... I've just received 2 more so hope 
> if was just a fluke ...  The guys over at 2cpu have some info about the board 
> if you want to pop over there and search around a bit
>>I have 6 Tyan Thunder K7 motherboards (Dual 1.2 GHz Athlon MP) in my
>>cluster. I am using Redhat7.2, kernel 2.4.9-13smp. The problem I get is
>>with the E-IDE driver. It does not correctly initialise the AMD7411 IDE 
>>controller and thus it can't go any faster than UDMA33 with the IDE hard
>>drives. You may have the same problem with the Tyan Tiger MP.
> _______________________________________________
> Beowulf mailing list, Beowulf at
> To change your subscription (digest mode or unsubscribe) visit

More information about the Beowulf mailing list