problems compiling mpich-1.2.1 on Linux PC

JParker at JParker at
Fri Mar 16 16:00:11 PST 2001

G'Day !

I use Debian, so I may be wrong, but didn't Redhat put a development 
compiler in the 7.0 release ?  Have you tried using a known stable version 
of GCC ?

Jim Parker

Sailboat racing is not a matter of life and death ....  It is far more 
important than that !!!

Frank Muldoon <fmuldoo at>
Sent by: beowulf-admin at
03/17/01 11:13 AM

        To:     beowulf at
        Subject:        problems compiling mpich-1.2.1 on Linux PC

I am having problems compiling mpich-1.2.1 on a PC running RedHat 7.0
using gcc.  I have tried a number of configure options and have always
gotten the same error when I try to compile mpich.  I have no problem
compiling it on an Alpha running unix.


gcc -DHAVE_SLOGCONF_H   -DMPI_LINUX  -c slog_irec_write.c -I..
slog_irec_write.c: In function `SLOG_Irec_SetMinRec':
slog_irec_write.c:1171: `SLOG_nodeID_t' is promoted to `int' when passed
through `...'
slog_irec_write.c:1171: (so you should pass `int' not `SLOG_nodeID_t' to
slog_irec_write.c:1172: `SLOG_cpuID_t' is promoted to `int' when passed
through `...'
make[7]: *** [slog_irec_write.o] Error 1
make[6]: *** [sloglib] Error 2
make[5]: *** [libslog.a] Error 2
make[4]: *** [default] Error 2
make[3]: *** [build_libs_progs] Error 2
make[2]: *** [mpelib] Error 1
make[1]: *** [mpi-addons] Error 2
make: *** [mpi] Error 2>

Frank Muldoon
Computational Fluid Dynamics Research Group
Louisiana State University
Baton Rouge, LA 70803
225-344-7676 (h)
225-388-5217 (w)

Beowulf mailing list, Beowulf at
To change your subscription (digest mode or unsubscribe) visit

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Beowulf mailing list