problems compiling mpich-1.2.1 on Linux PC

Frank Muldoon fmuldoo at
Sat Mar 17 11:13:13 PST 2001

I am having problems compiling mpich-1.2.1 on a PC running RedHat 7.0
using gcc.  I have tried a number of configure options and have always
gotten the same error when I try to compile mpich.  I have no problem
compiling it on an Alpha running unix.


gcc -DHAVE_SLOGCONF_H   -DMPI_LINUX  -c slog_irec_write.c -I..
slog_irec_write.c: In function `SLOG_Irec_SetMinRec':
slog_irec_write.c:1171: `SLOG_nodeID_t' is promoted to `int' when passed
through `...'
slog_irec_write.c:1171: (so you should pass `int' not `SLOG_nodeID_t' to
slog_irec_write.c:1172: `SLOG_cpuID_t' is promoted to `int' when passed
through `...'
make[7]: *** [slog_irec_write.o] Error 1
make[6]: *** [sloglib] Error 2
make[5]: *** [libslog.a] Error 2
make[4]: *** [default] Error 2
make[3]: *** [build_libs_progs] Error 2
make[2]: *** [mpelib] Error 1
make[1]: *** [mpi-addons] Error 2
make: *** [mpi] Error 2>

Frank Muldoon
Computational Fluid Dynamics Research Group
Louisiana State University
Baton Rouge, LA 70803
225-344-7676 (h)
225-388-5217 (w)

More information about the Beowulf mailing list