redhat 7.0 upgrade woes

Robert G. Brown rgb at
Tue Mar 6 14:46:52 PST 2001

On Tue, 6 Mar 2001, Jeffrey Oishi wrote:

> Hi--
> I'm trying to upgrade a 130 node cluster of machines with no video cards
> from RH6.1 to RH7.0. I have created an nfs-method kickstart system that
> works--if a video card is in the machine. If not, and I add
> console=ttyS0,9600n8 to the SYSLINUX.CFG, then the installer runs ok and
> starts spitting stuff out the serial port. However, the installer then
> crashes right before it starts upgrading the packages. It happily works up
> until the standard redhat screen showing each of the packages zipping by
> comes up. There it hangs. This has happened on a number of boxes.

Check the age/date of the actual release of RH7 you are using.  I had
somewhat similar problems trying to install an early version of 7 on a
slightly flaky system, although it did have a VGA card (it was still
using the non-X install).  Once the release was updated to current, it
worked fine.

I'm pretty sure kickstart should work, BTW, on a system with no video
and no console at all.  I haven't actually tried it, though, so I won't
swear to it.


Robert G. Brown	             
Duke University Dept. of Physics, Box 90305
Durham, N.C. 27708-0305
Phone: 1-919-660-2567  Fax: 919-660-2525     email:rgb at

More information about the Beowulf mailing list