Problems with 3c905C under Sycld

Jag agrajag at
Tue Jan 16 12:33:38 PST 2001

I have a slave node on a Scyld 2.0 preview release cluster that has a
3c905C NIC.  With the default Scyld setup, the NIC for some reason
autonegotiates down to 10MbaseT.  I narrowed the problem down to
accuring in the Stage 1 boot when it sends out RARP requests, it seemed
to take the interface down (there was a 100M link light when the machine
was powered on), then bring it back up at 10M.  After that everything
worked fine, except only at 10M.  I then followed the instructions for
adding a new driver and updated the driver beoboot uses to
3c59x.c:v0.99Qk  With this updated driver, when the interface is brought
back up in Stage 1, its brought back up at 100M, however when it gets to
Stage 3, the following error shows up repeatedly on the machine when it
tries to send out the RARP request:

eth0: Host error, status 8003, FIFO diagnostic register 0000.
eth0: PCI bus error, bus status 80000020, reset had 2000 tick left.

I also tried using the 3c90x version 1.0.0i driver.  I added it as a new
driver as indicated and also compiled it for the running kernel, added
it to /lib/modules/2.2.16-21.beo/net/ and remade the stage2 kernel
image, after adding it to a bootmodule line in /etc/beowulf/config.boot
This time it gets to Stage 3 without problems, but only gives these
lines, and just hangs:

boot: System boot phase 3 in progres.
boot: Reading config file from: config.boot
ioctl(SIOCSIFFLAGS): No such device

Any ideas on how to get this slave node working at 100M instead of 10M?

Thanks in advance

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
URL: <>

More information about the Beowulf mailing list