Hi,<br><br>I had an issue with 82574L before, and the Intel guys had to buy the same hardware for their lab in order to find and fix the issue.  It was a new SuperMicro motherboard:<br><a href="http://comments.gmane.org/gmane.linux.drivers.e1000.devel/6734">http://comments.gmane.org/gmane.linux.drivers.e1000.devel/6734</a><br>
<br>Are you using the latest driver from Intel?  I see you already link to the sourceforge fix:<br><a href="http://sourceforge.net/projects/e1000/files/e1000e%20stable/eeprom_fix_82574_or_82583/">http://sourceforge.net/projects/e1000/files/e1000e%20stable/eeprom_fix_82574_or_82583/</a><br>
<br>I would follow up with the Intel folks, get them to test with the new kernel.<br><br>Regards,<br>Alex<br><div class="gmail_extra"><br><br><div class="gmail_quote">On Tue, Dec 11, 2012 at 6:21 PM, Bill Broadley <span dir="ltr">&lt;<a href="mailto:bill@cse.ucdavis.edu" target="_blank">bill@cse.ucdavis.edu</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br>
Anyone have some working tweaks to get an Intel E1000e driver + 82574L<br>
chip to behave with linux 3.5 or 3.7 kernels?  Not sure if this is a<br>
problem for all 82574Ls or just ones on recent supermicro motherboards.<br>
<br>
I noticed stuttering, occasional high latencies, and a continuously<br>
increasing dropped packets from ifconfig:<br>
  RX packets:13437889 errors:0 dropped:14185 overruns:0 frame:0<br>
<br>
Even something simple like ping -c 100 would show at least one packet<br>
with over 1 second latencies.<br>
<br>
Several discussions mention that some of the errors are not logged, so<br>
it&#39;s may well be significantly worse than you&#39;d think from the dropped<br>
packet count.<br>
<br>
Replacing the cables, switch, or even the entire node doesn&#39;t seem to<br>
make any difference.   I&#39;ve found quite a few discussions about it,<br>
googling &quot;linux 82574L dropped&quot; finds quite a few.  Most that I found<br>
that provide details mention supermicro motherboards.<br>
<br>
There seems to be a solution for Centos 6, but I&#39;m having problems<br>
getting said fix to work with newer kernels.<br>
<br>
Some of the discussions:<br>
<br>
<a href="http://www.linuxquestions.org/questions/linux-hardware-18/intel-82574l-gigabit-network-card-issues-and-resolution-831364/" target="_blank">http://www.linuxquestions.org/questions/linux-hardware-18/intel-82574l-gigabit-network-card-issues-and-resolution-831364/</a><br>

<br>
<a href="http://www.doxer.org/learn-linux/resolved-intel-e1000e-driver-bug-on-82574l-ethernet-controller-causing-network-blipping/" target="_blank">http://www.doxer.org/learn-linux/resolved-intel-e1000e-driver-bug-on-82574l-ethernet-controller-causing-network-blipping/</a><br>

  <a href="https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1018561" target="_blank">https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1018561</a><br>
<br>
<a href="http://sourceforge.net/projects/e1000/files/e1000e%20stable/eeprom_fix_82574_or_82583/" target="_blank">http://sourceforge.net/projects/e1000/files/e1000e%20stable/eeprom_fix_82574_or_82583/</a><br>
<br>
This is mostly a concern for me because it&#39;s a noticeable performance<br>
problem and supermicro based resellers seem to be winning the cluster<br>
bids recently.  With newer Sandy Bridge, Ivy Bridge, Bulldozer, and<br>
Piledriver CPUs it seems worthwhile to run a relatively new kernel.<br>
<br>
Has anyone been successful with getting the 82574L to work as expected?<br>
 With a supermicro motherboard?<br>
<br>
I&#39;ve tried all the discussed fixes including but not limited to updating<br>
the driver, upgrading to from a 3.5 kernel -&gt; 3.7 kernel,<br>
turning pcie_aspm off, various e1000e.IntMode settings,<br>
e1000e.interruptthrottleRate, apci=off, disabling various features with<br>
ethtool, and patching the e1000e firmware.<br>
<br>
For such a popular chip and driver I&#39;m surprised that problems seem to<br>
be lingering.  Then again I suspect most people are happy when a network<br>
provides connectivity and not so much about performance.  Thus my email<br>
to the beowulf list.<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
_______________________________________________<br>
Beowulf mailing list, <a href="mailto:Beowulf@beowulf.org">Beowulf@beowulf.org</a> sponsored by Penguin Computing<br>
To change your subscription (digest mode or unsubscribe) visit <a href="http://www.beowulf.org/mailman/listinfo/beowulf" target="_blank">http://www.beowulf.org/mailman/listinfo/beowulf</a><br>
</blockquote></div><br></div>