[Beowulf] Trouble with MPICH-1.2.6 and PGI 6.0

Jeffrey B. Layton laytonjb at charter.net
Tue Jun 7 04:30:14 PDT 2005


  I'm having trouble compiling a F90 code with
MPICH-1.2.6 and PGI 6.0. I'm getting the following
error message from mpif90.

mpif90 -c -fastsse -tp k8-64 -Mbounds -Mchkptr -Mdclchk -Minform,inform 
-DPORTLAND_COMPILER kinddefs_module.f90
trap: usage: trap [-lp] [[arg] signal_spec ...]
/bin/rm: cannot remove `mpif.h': No such file or directory

I'm not sure what this means. I did find a part of the
mpif90 script that talks about linking mpif.h, but I'm
not sure how to fix the problem. Any suggestions?



More information about the Beowulf mailing list