problems with scyld - slave nodes

Sean Dilda agrajag at scyld.com
Tue Nov 6 14:24:55 PST 2001


On Tue, 06 Nov 2001, Son Nguyen wrote:

> >Message: 4
> >Date: Mon, 5 Nov 2001 12:19:06 -0600 (CST)
> >From: german kogan <gkogan at students.uiuc.edu>
> >To: <beowulf at beowulf.org>
> >Subject: problems with Scyld
> >
> >
> >
> >Hi.
> >
> >I am having problems with booting up slave nodes. Every time I try to do
> >it I get an error in the state column in the BeoSetup. I looked in the log
> >file for that node and it said
> >" setup_libs: Copying libraries to node 2...
> >tar:lib/ld-2.1.3.so: Cannot write: No space left on device
> >tar: Error exit delayed from previous errors
> >Library copy to node failed. (rootfs=/rootfs)"
> >
> >I cleaned up, deleted most of the partitions, on that node using the fdisk
> >utility from the Windows 98 start up disk. But still gives me the same
> >error. If somebody can help me out I would greatly appreciate it.
> >
> >Thanks
> 
> German,
> 
> it is not ram.  it is partition allocation.  your / partition is not enough. 
>   here is a suggestion
> 
> fat    50mb         beoboot
> swap   256mb        swap
> /      rest(1.4gig) rest
> 
> I have also found out that on certain testing of the filesystem, I can load 
> 100% of the / partition.  After a reboot, the slave node does not allow full 
> active state due to lack of space issues.


The problem is with the / partition.  However, on a fresh install of
Scyld Beowulf, the / partition is a ram disk, which means running out of
RAM may be the problem.  It won't try to put anything on the harddrive
of the slave node until you bring the nodes up with ramdisks and
partition them, then change the /etc/beowulf/fstab
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
Url : http://www.scyld.com/pipermail/beowulf/attachments/20011106/e68ccdaa/attachment.bin


More information about the Beowulf mailing list